WP Engine ofrece a todos los clientes soporte extendido para PHP 7.4

El 28 de noviembre, la versión apoyada por la comunidad de PHP 7.4 alcanzará el estado de Fin de vida (EOL), lo que significa que el equipo de desarrolladores de PHP que mantiene regularmente el lenguaje de codificación en versiones estables ya no proporcionará correcciones de errores, parches de seguridad o actualizaciones de seguridad críticas.

Si bien eso es parte del curso cuando se trata de PHP, actualmente cada versión de PHP es compatible durante dos años después de su lanzamiento inicial y está completamente obsoleta después de tres, el EOL de PHP 7.4 es único en WordPress, junto con una amplia gama de temas y complementos. , son aún no totalmente compatible con versiones más nuevas de PHP (8.0+).

Cómo verificar qué versión de PHP estás usando

Índice de contenidos
  1. Soporte extendido para clientes de WP Engine y Flywheel
  2. ¿Estás listo para actualizar a PHP 8.0?
  3. ¿Cuáles son los beneficios de PHP 8.0?
  4. Mantener sus sitios de WordPress, y su versión de PHP, a salvo de vulnerabilidades

Soporte extendido para clientes de WP Engine y Flywheel

Si bien preferimos que todos nuestros clientes actualicen a las últimas versiones de WordPress y PHP, también entendemos que hacerlo ahora mismo podría generar errores críticos en sus sitios web.

Eso es lo último que queremos, pero al mismo tiempo, WP Engine siempre ha trabajado arduamente para evitar que nuestros clientes usen versiones no compatibles de PHP (o cualquier otro software) ya que puede abrir sus sitios y nuestra plataforma, a los riesgos de seguridad.

Con eso en mente, WP Engine ha invertido en soporte de seguridad continuo para PHP 7.4. Esto permitirá que todos nuestros clientes, en WP Engine y Flywheel, permanezcan en PHP 7.4 después de la fecha de EOL del 28 de noviembre, mientras mantienen seguros sus sitios y nuestra plataforma. También es actualmente la única oferta de este tipo para soporte extendido de PHP 7.4 por parte de un proveedor de plataforma administrada.

Si bien aún no hemos determinado una nueva fecha límite para que los clientes dejen de usar PHP 7.4, creemos que el tiempo adicional les brindará a ellos, a la comunidad más amplia de WordPress y a los desarrolladores individuales de complementos y temas la ventana que necesitan para resolver las incompatibilidades abiertas.

Como proveedor administrado que está profundamente involucrado con la comunidad de WordPress, entendemos los puntos débiles actuales que rodean la compatibilidad con PHP 8.0 y vemos esto como una oportunidad para brindar a nuestros clientes un servicio muy necesario: soporte de seguridad extendido. Con eso en mente, WP Engine no requerirá que los clientes actualicen de PHP 7.4 a PHP 8.0 en la fecha de EOL, 28 de noviembre de 2022.

Si tiene alguna pregunta, comuníquese con nuestros equipos de soporte a través del Portal de usuario de WP Engine, el Aplicación de volanteo cualquiera de las opciones enumeradas aquí.


¿Estás listo para actualizar a PHP 8.0?

Tiempo problemas de compatibilidad son algo que debe tener en cuenta, los clientes de WP Engine pueden realizar la actualización a PHP 8.0, si así lo desean.

Independientemente de los problemas de compatibilidad conocidos, WP Engine siempre recomienda que las actualizaciones del sitio se realicen en un entorno de prueba o desarrollo para garantizar que su sitio en vivo se mantenga seguro. Esto también le dará la opción de probar problemas de compatibilidad antes de publicar su sitio actualizado.

Realizar la actualización por su cuenta es un proceso simple: simplemente inicie sesión en su portal de usuario y siga los pasos que se proporcionan aquí. Si aún tiene preguntas, puede iniciar sesión en su cuenta para ponerse en contacto con el soporte.


¿Cuáles son los beneficios de PHP 8.0?

Hay una serie de mejoras y nuevas características que vienen con PHP 8.0, que incluyen:

Si bien, en general, ejecutar una versión actualizada de PHP acelerará su sitio (la actualización a 7.4 el año pasado experimentó un aumento significativo de la velocidad en los sitios de nuestros clientes), también evita que los malhechores se aprovechen de las vulnerabilidades de seguridad que podrían estar al acecho en versiones anteriores de PHP, un factor importante en nuestra decisión de invertir en soporte extendido de PHP 7.4.


Mantener sus sitios de WordPress, y su versión de PHP, a salvo de vulnerabilidades

Con el soporte extendido de WP Engine para PHP 7.4, los clientes no necesitan preocuparse por las vulnerabilidades en esa versión (y no se han señalado vulnerabilidades actuales).

Dicho esto, todos los clientes de WP Engine y Flywheel actualmente usan PHP 7.4, 8.0 o superior, y dar el salto (o prepararse para dar el salto) a 8.0 desde versiones anteriores de PHP es algo que debe comenzar a considerar.

Puede echar un vistazo más de cerca a la compatibilidad de PHP con versiones específicas de WordPress aquí así como una lista de los avisos de obsolescencia restantes (relacionados con la incompatibilidad) en WordPress 5.9 aquí.

Quieres saber más? Hable hoy con un experto en WordPress de WP Engine, o echa un vistazo a nuestro Guía de actualización y versión de PHP para más detalles.

Deja una respuesta

Subir